Ultimamente he estado trabajando mas con WordPress, mas especificamente con mi blog y haciendo algunas actualizaciones, he detectado que uno de los problemas mas comunes que tenemos nosotros los habla hispanos es que los temas no tiene otros idiomas, y para esto es necesario crear un archivo .po para establecer el cambio de idioma en nuestro wordpress.

Los archivos .po y .mo son un tipo de fichero que se utilizan para la traducción de interfaces a múltiples idiomas. Por un lado está el archivo .po donde podemos ver de forma comprensible cada uno de los campos y su traducción y por otra, el archivo .mo, es el que la “máquina” interpreta para mostrarnos la interfaz de la aplicación

Es importante que antes de empezar estes seguro que el idioma de tu wordpress es igual al que estarás editando, dentro del archvio config.php debe estar seleccionado el lenguaje (es_MX), para el caso de México, o (es_Es)

Traducir un WordPress

  1. Busca, instala y activa el plugin Codestyling Localization desde el menú plugins del panel de control de WordPress. Plugins -> Añadir nuevo y buscamos “Codestyling Localization
  2. Una vez instalado en el menú Herramientas aparecerá una nueva opción item llamada Localización. Si hacemos click en él nos mostrará los temas y plugins instalados, así como los idiomas inicialmente disponibles para cada uno.
  3. Si efectivamente falta el idioma español en el tema o plugin que vayamos a traducir, tendremos que añadirlo pulsando en el botón “Añadir nuevo idioma”
  4. Una vez añadido el idioma hacemos click en “volver a escanear” y escaneamos el plugin o tema elegido. Esto puede llevar un tiempo. Cuando haya finalizado el escaneo tan solo tendremos que hacer click en editar y comenzar el proceso de traducción, buscando la palabra y editando la version que queremos en el blog.
  5. Una vez estemos contentos con la traducción, generar el archivo .mo es tan fácil hacer click obre el botón que dice  GENERAR .mo. En este momento ya tendremos la plantilla o plugin traducida.

Captura de pantalla 2014-02-04 a la(s) 10.39.23

El proceso de escaneo puede requerir bastantes recursos del sistema. Si recibes un mensaje de error avisándote de que no hay memoria suficiente para realizarlo, asegurate de marcar la opción enable low memory mode que encontrarás en la parte superior a la izquierda de la pantalla del plugin.

 

Share This